Error al actualizar Metasploit - svn: E175002

Uno nunca se cansa de aprender cada día cosas nuevas, es por eso que cada profesión siempre exige investigación todos los días. En los ratos libres sigo practicando seguridad con nuestro querido Backtrack y una de sus herramientas incluidas que es Metasploit.

Como sabemos todos, cada vez que se vaya a usar dicha herramienta hay que actualizarla, ya que nos descarga las últimas actualizaciones de exploits, payloads, etc; que se tengan en los repositorios oficiales de la misma. Cuando me propuse hacerlo con el comando msfupdate me sacó el siguiente error:


svn: E175002: Unable to connect to a repository at URL 
'https://www.metasploit.com/svn/framework3/trunk'

y más abajo decía que el certificado no era válido. Comenzé a buscar y esto fue lo que hice:

1. En la consola de Backtrack ir a la ruta /opt/metasploit/msf3/

2. Editar el archivo msfupdate 

3. Dentro del archivo agregamos la siguiente línea

@args.push("--trust-server-cert")  

Pero la agregamos debajo de la que dice: @args.push("--non-interactive") , como se ve en la gráfica 
4. Guardamos el archivo y ejecutamos el msfupdate 

 Y Voilá! Presto updated

Saludos!!
 

1 comentario:

  1. Gracias por el aporte me funciono perfectamente.... :)

    ResponderEliminar