Configurar Tarjeta wireless Broadcom4312 con el Kernel 2.6.32-5-686


Como buen amante de la informática trato de actualizar mi sistema cada vez que se requiera.....bueno en la medida de lo posible. Se que la versión del kernel que está en el título de la entrada no es la última pero de igual manera actualizé a esa versión para probarla. Como es lógico hay dispositivos que no configura por default entre ellos la tarjeta inalámbrica Broadcom 4312. Para los que tienen Debian Lenny aquí se los dejo:



1. Instalamos los paquetes build-essential, debhelper, module-assistant, quilt y wireless-tools

# apt-get update
# apt-get install build-essential debhelper module-assistant quilt wireless-tools

2. Descargamos el paquete squeeze/broadcom-sta-source de alguno de los mirrors de Debian

# wget http://ftp.us.debian.org/debian/pool/non-free/b/broadcom-sta/broadcom-sta-source_5.60.48.36-2_all.deb

3. Descargamos squeeze/broadcom-sta-common

# wget http://ftp.us.debian.org/debian/pool/non-free/b/broadcom-sta/broadcom-sta-common_5.60.48.36-2_all.deb

4. Instalamos los paquetes que acabamos de bajar

# dpkg -i broadcom-sta-*deb

5. Compilar e instalar el paquete broadcom-sta-modules-* para su sistema, utilizando Module-Assistant

 # m-a a-i broadcom-sta

6. Para las tarjetas BCM4313, BCM43224 Y BCM43225 agregamos al blacklist el módulo brcm80211para evitar conflictos con su soporte

# echo blacklist brcm80211 >> /etc/modprobe.d/broadcom-sta-common.conf


7. Reconstruimos el ramdisk inicial y lo agregamos al blacklist los módulos definidos en el archivo /etc/modprobe.d/broadcom-sta-common.conf con initramfs

# update-initramfs -u -k $(uname -r)

8. Descargamos los módulos conflictivos

# modprobe -r b44 b43 b43legacy ssb brcm80211

9. Cargar el módulo wl

# modprobe wl

10. Verificamos que la tarjeta se haya reconocido

# iwconfig

Por último configuramos la intefaz inalámbrica. Para los que tengan otras versiones de Debian tambien se puede hacer. Les dejo la fuente para que consulten. En ella hablan de actualizarlo con el kernel 2.6.38 pero tambien aplica para el kernel tratado aquí.

Fuente: http://usemoslinux.blogspot.com/2011/04/tarjetas-wireless-broadcom-con-kernel.html

0 comentarios: